Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug 2020.1 a14 won't launch after closing (needs windows reboot every time to start)

Discussion in '2020.1 Beta' started by m0nsky, Nov 22, 2019.

  1. m0nsky

    m0nsky

    Joined:
    Dec 9, 2015
    Posts:
    263
    After closing the editor, it won't start again. The Unity splash screen shows, and then goes back to the hub.

    After rebooting windows, everything will work fine, until I close the editor. Then it will not open any projects in the a14 editor until I reboot my computer.

    I think there is some kind of event not firing correctly when starting the editor for the second time. If I wipe my library folder, it does not get recreated (until reboot) either.

    I'm using a personal license, and didn't have this issue on any earlier 2020.1 alpha up to a12.
     
  2. petersx

    petersx

    Joined:
    Mar 5, 2015
    Posts:
    239
    Hi,

    Do you have latest hub version ? Last time I have similar situation with no latest hub.

    BTW. 2020.1a14 is not usable with HDRP & RayTracing - when start rendering scene it slow down slow down .. and crash :(
     
  3. m0nsky

    m0nsky

    Joined:
    Dec 9, 2015
    Posts:
    263
    I'm on Unity Hub 2.1.3. I just uninstalled it and downloaded the installer from the website which also installed 2.1.3, so it must be the latest. The problem still persists.

    Edit
    Fixed by deleting my "C:\ProgramData\Unity" folder. Not recommended.
     
    Last edited: Nov 22, 2019
  4. Lex4art

    Lex4art

    Joined:
    Nov 17, 2012
    Posts:
    455
    This problem probably caused by latest Nvidia drivers. Previous driver will work fine, probably (Studio driver 441.12 is working fine for me, 441.28 - crash & project won't load). Just don't tweak "Bounces" parameter for ray-traced GI, it will always crash no matter the driver.
     
  5. m0nsky

    m0nsky

    Joined:
    Dec 9, 2015
    Posts:
    263
    Yeah that's a different issue, I experienced that too a while ago.
     
  6. Deleted User

    Deleted User

    Guest

    You probably needed to delete the Unity_lic.ulf file only, not the entire directory.

    Pass the word if you see other people having the problem, please. I'm tired of posting this.
     
  7. Rob-A

    Rob-A

    Joined:
    Aug 7, 2012
    Posts:
    33
    Renew your license. There is a problem with licenses becomming invalid. The worst about it is the you will only see this in the log file of the editor.
    Unity needs to add a more user friendly error feedback than just closing the editor and reopening the hub.
     
  8. m0nsky

    m0nsky

    Joined:
    Dec 9, 2015
    Posts:
    263
    The hub said my license was valid. The first thing I tried was to return my license and activate a new one, which didn't help. That's when I deleted the programdata folder because I noticed it contained a few cache directories.