Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

2020.1.5f1 Alt Fix for Failed to Load Window Layout

Discussion in 'Unity Hub' started by BluXombie, Sep 13, 2020.

  1. BluXombie

    BluXombie

    Joined:
    Aug 30, 2020
    Posts:
    1
    For anyone running into the Failed to Load Window Layout in 2020.1.5f1, here is what worked for me;

    Issue:

    Starting new or attempting to open an existing project in Unity 2020.1.5f1 results in "Failed to Load Window Layout" and no other choice but to quit

    Final Fix:
    - Successfully installed and ran 2019.4.10f1 in Unity Hub
    - Successfully started a new project with 2019.4.10f1 and exited
    - Upgraded new 2019 project to 2020.1.5f1 in Unity Hub and the project opened successfully (Problem Solved)

    Additional Information:


    Environment:
    Windows 10 64x

    Actions Taken that did not resolve the issue (so you don't waste your time trying):
    - Deleted all projects and starting new ones (make copies elsewhere if you do this)
    - Deleted the original project folder and added a new path/folder
    - Tried to start new projects
    - Tried to open old projects
    - Uninstalled Unity 2020.1.5f1 and reinstalled within the hub
    - Uninstalled Unity Hub itself and reinstalled
    - Deleted all Unity registry keys under HKEY_CURRENT_USER, LOCAL_MACHINE, &CLASSES_ROOT after uninstall
    - Installed Unity on (C drive (issue started on (D) and used the old project folder as well as added a new folder on (D drive
    - Reinstalled Unity Hub back on (D which was the original drive when the issue started.
     
    Last edited: Sep 13, 2020