Search Unity

2018.3 Terrain editing *really* slow

Discussion in 'World Building' started by LesBloom, Dec 13, 2018.

  1. LesBloom

    LesBloom

    Joined:
    Feb 2, 2017
    Posts:
    167
    Hello,

    I am new to the terrain system as a whole. Hopefully there is something really basic that I am missing. It's a really basic terrain; it' just a quick test to learn the system.

    I make one two height adjustments and the whole terrain is black for a while. It appears to be performing a bake process. During this time it's pretty hard to make any more edits, because I can't see the terrain that is being adjusted. This lasts for minutes at a time. It is currently very tedious to edit my terrain this way.

    I don't think it's my machine specs. I have a pretty top end rig that I use for VR development. Currently, the Unity Editor is consuming 14GB of ram. I have tried closing and relaunching Unity, but I get the same results each time.

    Is there some sort of 'fast edit' setting that I can toggle between while making edits?

    Thank you for your time
    Lester
     
  2. ChrisTchou

    ChrisTchou

    Unity Technologies

    Joined:
    Apr 26, 2017
    Posts:
    74
    Make sure to turn off automatic lightmap / GI baking, it tends to fight with the terrain system for GPU/CPU time while you are editing the terrain (and also is constantly starting over every time you change the terrain, leading to the black ambient lighting).

    In the menu: Window -> Rendering -> Lighting Settings, turn off "Auto Generate" at the bottom.

    We're looking into ways to make them play better together in the future.
     
  3. LesBloom

    LesBloom

    Joined:
    Feb 2, 2017
    Posts:
    167
    That is exactly what I was looking for. Thank you
     
  4. wyattt_

    wyattt_

    Unity Technologies

    Joined:
    May 9, 2018
    Posts:
    424
    You can also enable Draw Instanced in the Terrain Settings
     
  5. SveinEven

    SveinEven

    Joined:
    Sep 25, 2014
    Posts:
    99
    I'm sorry to hijack a thread like this, but I also have problems with the terrain in 2018.3.
    After the update, the frame rate while editing dropped to at least half of what it used to be.

    There is no light generation going on, and trying to enable Draw Instanced "removes" the terrain.
    It looks like the terrain is simply disabled.
     
  6. Lars-Steenhoff

    Lars-Steenhoff

    Joined:
    Aug 7, 2007
    Posts:
    3,524
    Would be good if auto generate has a user setting for how long to wait before generating.

    For example after 5 seconds of no user input start baking.
     
  7. wyattt_

    wyattt_

    Unity Technologies

    Joined:
    May 9, 2018
    Posts:
    424
    Are you using an SRP or the Built-in Renderer?