Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  4. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

[2018.2] Strange behaviour Cinemachine Collider + Free Look

Discussion in 'Cinemachine' started by Mars91, Sep 6, 2018.

  1. Mars91

    Mars91

    Joined:
    Mar 6, 2012
    Posts:
    343
    Hi,
    I'm using Cinemachine to follow the player and I'm experiencing some strange behaviour on camera collision.
    Here's a video.


    Here's a pic of my FreeLook/Collider configuration
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,533
    What's happening is that the camera, which is a big ball of radius 0.3, is colliding with the corners of your columns. There are a few things you can do to mitigate this in the Collider settings:
    • Reduce the camera radius to be as small as you can get away with
    • Put in a little smoothing time, some fraction of a second. That stops the camera from popping around so much
    • Add some Damping and Damping When Occluded (the first should be set a little smaller than the second)
    If that fails to give you what you want, then you can add some invisible cylindrical colliders (on a layer that only the vcam can collide with) around your columns, to smooth out your environment.
     
  3. Mars91

    Mars91

    Joined:
    Mar 6, 2012
    Posts:
    343
    Looks like I made it here's my settings

    Camera Radius: 0.05
    Smoothing Time: 0.1
    Damping: 0.25
    Damping When Occluded: 0.35
     
    Gregoryl likes this.