Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

2018.2.0b5 keeps getting stuck in loop importing shaders (also was in b2, started in 2018.2)

Discussion in 'Graphics Experimental Previews' started by XRA, May 27, 2018.

  1. XRA

    XRA

    Joined:
    Aug 26, 2010
    Posts:
    265
    Anyone else seeing this? it is making it difficult to do anything as the editor keeps reimporting the same shaders anytime it gets focus, I have to kill the Unity process. Then it stops next time but eventually comes back.

    I've tried deleting the library folder and it eventually came back, project is too big to keep doing that.

    Don't have a good repro so haven't made a bug yet but curious if it has been observed by others.
     
  2. hippocoder

    hippocoder

    Digital Ape

    Joined:
    Apr 11, 2010
    Posts:
    29,723
    Doesn't sound like anything recognisable. Were you making a build, any extra info, is it HD etc etc... Needs info badly. Also by making stripped down version of the project you're likely to catch what causes it.
     
  3. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    789
    This happened to me when I tried the master version of the SRP HDRP from GitHub a few days ago without fully knowing how to setup the reorganization of the folders etc. So I added it to my asset folder like always just in case it worked and it did but I had this problem along with it. After the Devs posted how things were set up and I followed that everything was back to normal. Don't know if you did the same thing but this is how it happened on my end.
     
  4. hippocoder

    hippocoder

    Digital Ape

    Joined:
    Apr 11, 2010
    Posts:
    29,723
    It's a graphics experimental preview issue (HDRP). I'll move this thread over there now. Sounds like shader stripping (or lack of). Used package manager?
     
  5. XRA

    XRA

    Joined:
    Aug 26, 2010
    Posts:
    265
    Yeah I had brought in the github SRP, I think it is the same as Gimreaper358 mentions. I moved it out of my assets folder and the issue went away, was just using it as reference custom pipeline, still using CoreRP and having no reimport trouble.
     
  6. XRA

    XRA

    Joined:
    Aug 26, 2010
    Posts:
    265
    *edit*
    no long getting the issue (it would kick off importing shaders & repeat anytime Unity editor gets focus in windows)

    I moved my custom shaders out of Assets, then brought them back in one at a time only as needed, not sure if it was meta files or some of the #include file changes I made during that. There were some HLSL file includes inside CGPROGRAM blocks which was not right.

    when it was getting stuck it would occasionally spam the error
    Assertion failed on expression: 's_AssetProgressBar.dialog'
     
    Last edited: May 28, 2018