Search Unity

2018.1 HDRP shadows and quality settings

Discussion in 'Editor & General Support' started by TranSystems, May 2, 2018.

  1. TranSystems


    Jan 10, 2018
    So, I seem to be missing something with the 2018.1.0f2 High Definition Render Pipeline. The example workshop scene that loads with it looks great, but I need to know how to get that level of image quality for a large scale scene (highway interchange), especially when it comes to shadows and lighting. When I pull the view back from the scene assets, the shadow quality cuts off quickly and dramatically.

    This is for an arch viz animation, so I am not concerned about realtime performance, just a high quality image. Any guidance?

    Attached Files:

  2. lucasmnribeiro


    Oct 17, 2018
    I know it's an old thread but it seems that there's no answer to it on google yet. So, studying the 'Book of the Dead' demo scene I found a way to tweak the shadow render. On your 'Hierarchy' click on 'Volume Settings'. Then open the 'HD Shadow Settings' menu and use that options to configure the shadow draw distance. I'm using on my scene at the moment:

    Max Distance : 150
    Cascade Count: 4
    Split 1: 0,144
    Split 2: 0,267
    Split 3: 0,372

    I don't know how much this hits the performance but I didn't noticed any diference.