Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

2018.1.1f1 Render Pass Install Crash

Discussion in 'Graphics Experimental Previews' started by DJ_Kim, May 30, 2018.

  1. DJ_Kim

    DJ_Kim

    Joined:
    Feb 1, 2018
    Posts:
    9
    Making new Project with new Render pass(HDRP, LRP) crashes during installation.

    Making new Project with 3D template(built-in) and installing from Package Manager also crashes.

    I have attached screenshot of when it crashes.

    Everytime on the loading, it seems to crash at AutoExposure.compte(?)

    I cannot find any solution up on online.

    I have deleted Unity and reinstalled also.

    Please help me. RenderPassInstallCrash.jpg
     
  2. staticbl

    staticbl

    Joined:
    Jul 1, 2016
    Posts:
    12
    Hello,

    I have exacty the same problem, on both versions 2018.1.1 and 2018.1.2.

    I have the problem on new projects or existing projects. One existing project for which I have enabled the "LWRP" package crashed when reaching AutoExposure.Compute, and now I can't open it (it crashed the same way each time).

    I am now stuck because I can't work on my current project anymore ! Any suggestions ? Thanks !
     
  3. DJ_Kim

    DJ_Kim

    Joined:
    Feb 1, 2018
    Posts:
    9
    One thing I noticed is that when you install it locally, meaning, downloading the whole folder of SRP files and copying it into unity folder works fine.

    So the problem might be on downloading process.(Package manager or something)
     
  4. staticbl

    staticbl

    Joined:
    Jul 1, 2016
    Posts:
    12
    Thanks for the heads up - I'm wondering, do you just download it from the Git page and drop it into your project folder ?
     
    unity_S9MRG1-P52xY3g likes this.
  5. staticbl

    staticbl

    Joined:
    Jul 1, 2016
    Posts:
    12
    I've noticed this problem occurs when downloading various packages from the package manager (for example, post processing, shadergraph or LWRP). Does anyone else have this problem ? How can I install them manually ? Thanks ! :)

    EDIT : Out of despair, I went to the Unity Cache folder and manually deleted "autoexposure.compute" (file & meta), since this is the file that seemed to cause the crash, and then copied the package folders to my unity project. I can now open my project again, and I can now use the Lightweight Rendering Pile Line with Shader Graph, which was my initial goal.

    Is it a problem that I deleted AutoExposure.compute ?

    Thanks !
     
    Last edited: Jun 10, 2018
    unity_S9MRG1-P52xY3g likes this.
  6. unity_S9MRG1-P52xY3g

    unity_S9MRG1-P52xY3g

    Joined:
    Jun 21, 2018
    Posts:
    1
    Just a little heads up, I'm working on this problem right now too. Curious to see if anyone has made any headway - and I'd also like to point out that we've had the problem on two computers with English Windows 7, but we haven't had the problem on two computers with Japanese Windows 7. So there's that.