Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

2017.3 f2 - Is the inspector preview of prefabs/meshes slow as molasses for anyone else but me?

Discussion in '2017.3 Beta' started by Jaimi, Dec 14, 2017.

  1. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    6,071
    Some models/prefabs drag the whole system down when it shows the preview. Anyone else seeing this?
     
  2. Claytonious

    Claytonious

    Joined:
    Feb 16, 2009
    Posts:
    829
    I haven't run into this yet. I'm on Macbook Pro when using 2017.3f2.
     
  3. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    3,021
    Hi Jaimi,
    Could you please submit a bug report with a minimal reproduction project attached for this issue?
     
  4. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    6,071
    Case 979369

    I have managed to duplicate it in a smaller project. It appears to be a problem when previewing prefabs in the inspector. If I dump a bunch of prefabs (same one) into a scene, the scene is still very fast. But if you i click on the prefab in the project to view the original prefab in the inspector, it slows the system to a crawl (the more prefabs you have in a scene, the slower it is).

    Note that I am testing on a Surface Pro with Iris 540pro graphics, with 16GB of ram.
     
    LeonhardP and Peter77 like this.
  5. Evaldas_Unity

    Evaldas_Unity

    Unity Technologies

    Joined:
    Jun 23, 2016
    Posts:
    64
    I am going to shed some light on this. (hue hue, get it? because this was a lighting issue)

    You have correctly diagnosed why this happens, except one tiny detail - Auto baking lighting.

    So, we have already fixed this (as part of another issue) in 2018.1, but the backports are still pending (sad face).
    As a workaround (for now) disable auto baking of light?
     
    Last edited: Dec 18, 2017
  6. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    6,071

    Your response was very illuminating. Disabling the auto baking does indeed make this work better. Thank you for not keeping us in the dark.
     
  7. laurentlavigne

    laurentlavigne

    Joined:
    Aug 16, 2012
    Posts:
    5,749
    I would like to see these two on stage in the next Unite.
     
    charlesb_rm likes this.