Search Unity

  1. We would like to hear your feedback about Unity and our products. Click here for more information.
    Dismiss Notice

2017.3 Editor overhead performance degradation ?

Discussion in 'Editor & General Support' started by SBS_User, Dec 22, 2017.

  1. SBS_User

    SBS_User

    Joined:
    Apr 19, 2014
    Posts:
    63


    I did not noticed this kind of behavior in 2017.2. It does not matter if I run it in maximized or in editor. FYI its VR game project.
     
    SaSha_K likes this.
  2. snacktime

    snacktime

    Joined:
    Apr 15, 2013
    Posts:
    2,211
    I had that same thing happen on PC using the latest 2017.3. But it only happened once so no clue what triggered it.
     
  3. SBS_User

    SBS_User

    Joined:
    Apr 19, 2014
    Posts:
    63
    Installed patch one. More or less stable now. Also noticed that windows defender realtime protection messes up with Unity. had to turn it off.
     
  4. Gruguir

    Gruguir

    Joined:
    Nov 30, 2010
    Posts:
    311
    I'm also seeing that issue. Will try p1 ( edit : p1 didn't help). it's really annoying as i was working specifically on optimisation using profiler, and it makes it difficult to read.
     
    Last edited: Dec 29, 2017
  5. esteban16108

    esteban16108

    Joined:
    Jan 23, 2014
    Posts:
    57
    I'm seeing this all the time... after some time testing my game in the Editor it starts lagging, so I open the profiler and find out that it's the EditorOverhead taking all the CPU
     
  6. erre-rox

    erre-rox

    Joined:
    Dec 3, 2012
    Posts:
    10
    Any news about this? I've tried to update to 2017.3.0p4 but the problem still exists.
     
  7. MJost

    MJost

    Joined:
    Jul 28, 2015
    Posts:
    7
    I got the same issue and it makes it impossible to work on the balancing :(
    Tried every patch (1-4) and also beta 2018.1.b2, nothing helped. Issue is there most of the time. There are times where it runs normal, but 80% of the time I'm looking at 3FPS instead of 60...

    upload_2018-2-4_10-48-21.png
     
  8. MostHated

    MostHated

    Joined:
    Nov 29, 2015
    Posts:
    703
    Glad I'm not the only one. It seems to keep getting worse each day.
     
  9. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,389
    The same here! 24ms editor overhead..without scene view opened. nothing selected in the editor
     
  10. mster50-2

    mster50-2

    Joined:
    May 28, 2013
    Posts:
    14
    Adding to this, happens to me as well, frequently.
     
  11. Gruguir

    Gruguir

    Joined:
    Nov 30, 2010
    Posts:
    311
    and... no reaction from UT staff ?
     
  12. GPSTVR

    GPSTVR

    Joined:
    Nov 4, 2016
    Posts:
    5
    The same problem for me, really annoying upgraded to 2017.3.1f1 problem still here...
     
  13. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,389
    The same with 2017.3.1.p1
     
  14. YondernautsGames

    YondernautsGames

    Joined:
    Nov 24, 2014
    Posts:
    58
    I've been getting it for a while. Currently on 2017.3.1f1 and it decimates my framerate. I was also getting it on 5.6, which is why i updated.

    The only thing I can think of that could be doing it is that fairly soon before it started I did a pass of adding OnValidate to a lot of my behaviours, since I am looking to distribute them to other developers and want them to be relatively bomb proof. One thing I do occasionally is add optional references:

    Code (CSharp):
    1. public class OnValidateTest : MonoBehaviour
    2. {
    3.     [SerializeField] private RigidBody m_RigidBody;
    4.  
    5.     void OnValidate ()
    6.     {
    7.         if (m_RigidBody == null)
    8.             m_RigidBody = GetComponent<RigidBody> ();
    9.     }
    10. }
    I think I saw this done in the UNet source, and thought it was a good idea. It allows more flexibility than getting the reference in Awake, but means that when the user first attaches the component it automatically fills out the reference. It might be that this is a terrible plan.

    Once I have some time, I will go through and comment out all of these and report back on whether it had anything to do with it. I just wanted to post it in case it's similar to what anybody else is doing here.
     
  15. YondernautsGames

    YondernautsGames

    Joined:
    Nov 24, 2014
    Posts:
    58
    Nope. I went through and removed all OnValidates from my own code, but the performance hit was still there. There is no performance impact if I have nothing selected with inspector components other than transform. I'm not using any custom editors, or external code assets that can be affecting the inspector either. Completely stumped.
     
    twobob likes this.
  16. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,389
    In my case, when I tried to profile the Editor itself, it was doing something like finding gameobject with some specific tags.. Not sure if this has anything got to do with the slow down... the search was actually under the editor overhead, nothing to do with my own code or game. Some people says it is DX11. I am yet to try the force opengl solution. :(

    Still the same issue with 2017.3.1.p2
     
  17. essimoon2

    essimoon2

    Joined:
    Nov 13, 2013
    Posts:
    191
    Have the same problem but so far I'm the only one in my team and slowly going mad because of it :'D
    The editor becomes ridiculously slow, expecially when I work in the animation window or shuriken.
    Have to reboot the PC to fix it each time :/
     
  18. opponent019_unity

    opponent019_unity

    Joined:
    Feb 1, 2018
    Posts:
    2
    I'm having the same issues, even with latest 2018 beta :/
    Doesn't matter if it's DX11 or OpenGL for me. I tried importing my files in new project and still; I'm only working with 2 shaders although they're a bit heavy it shouldn't be doing this. I wouldn't mind to share them with someone looking for a solution. Even after taking everything out the fps is still like 70 tops when there's nothing in the scene.

    Specs: laptop Lenovo y510
    16GB RAM
    Nvidia GeForce GTX 960m (2GB)
    i7-4720HQ @2.6GHz
     
  19. Artaani

    Artaani

    Joined:
    Aug 5, 2012
    Posts:
    403
    Same here.
    9000 ms Editor Overhead in big VR project!
    Worked fine in 2017.1 and 5.6
    Performance of Unity becoming worse and worse : (
     
  20. Artaani

    Artaani

    Joined:
    Aug 5, 2012
    Posts:
    403
    Last edited: Mar 17, 2018
  21. BoaNeo

    BoaNeo

    Joined:
    Feb 21, 2013
    Posts:
    34
    Just for completeness, this is not a DX issue, or a windows issue for that matter. I'm seeing the same on OsX.

    It seems 2017.3 is a real lemon. I was getting ready to downgrade to 2017.2 for the third time due to yet another RectTransform bug when I realized that the performance issue I was having was also 2017.3 related.

    I guess if you have any type of deadlines or customer-relations to care about you're well advised to stay at least one major version behind the latest.
     
  22. Dizzy-Jump

    Dizzy-Jump

    Joined:
    Oct 9, 2014
    Posts:
    10
    same problem :(
     
  23. tzivaeris

    tzivaeris

    Joined:
    Mar 21, 2018
    Posts:
    4
    I have the same problem. I use unity 2017.3.1f1.My project has about 20 scenes and it is about 2GB of data.

    It seems that I get 98% of EditorOverhead and the editor works with about 3 fps.
    The strange thing is that it starts ok and after 1 hour or so the project becomes unstable and the editor drops frames. I have to import the project files again from the begining and create a new one!

    Anyone thinks that my project has flaws?
    Because when I try a new project with a demo scene from another project I see no degradation.
     
  24. AlkisFortuneFish

    AlkisFortuneFish

    Joined:
    Apr 26, 2013
    Posts:
    508
    Where is that time spent, if you use Profile Editor and, if necessary, deep profiling?
     
  25. Lesnikus

    Lesnikus

    Joined:
    Aug 29, 2015
    Posts:
    47
    What a horror! I switched from 5.6 to 2018.1.0b10 and the editor overhead eats 99%! 1 frame per second! I'm going back to 5.6 ...
     
    Artaani likes this.
  26. tzivaeris

    tzivaeris

    Joined:
    Mar 21, 2018
    Posts:
    4
    I think it is my graphic card. I am investigating more....
     
  27. Alex-Makovsky

    Alex-Makovsky

    Joined:
    Jan 26, 2013
    Posts:
    13
    I have same problems. Looks like it's a leak in editor. Because after reloading Unity3d I have 1200 FPS on first running of my project, but after first minute of running I have 30-50 FPS and 75% "Editor Overhead" in profile.
    PS I have Unity 2018 beta. Trying to run in 2017.3 - same problems.
    PPS win 10
     
  28. Alex-Makovsky

    Alex-Makovsky

    Joined:
    Jan 26, 2013
    Posts:
    13
    UPD: It's strange. I turn off windows firewall and my problem with "editor overhead" was disappeared.
     
    twobob and SaSha_K like this.
  29. m00g00

    m00g00

    Joined:
    Jan 20, 2013
    Posts:
    1
    I have a brand new blank scene, new project, nothing loaded. Windows firewall disabled, and editor overhead taking up 7ms. Any word from the staff on this issue??
     
  30. buFFalo94

    buFFalo94

    Joined:
    Sep 14, 2015
    Posts:
    181
    Same here on 2017.3.1p1 but when adding Unity installation folder to Window Defender exclusion, the Profiler seems to be more stable but not as stable as it was in 5.6.4px I'm still experiencing some spikes
     
  31. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,389
    The same thing here.. runs at about 30fps on first play (on GTX 970) and then slowly gets worse over time till like 5 fps.
    the build of the game runs like 250 fps...

    So this "seems" to be fixed in 2018.2 ??? Oh come on now...! The bug was introduced at 2017.3.. it should be fixed for 2017.3 or 2017.4 (because now it is in LT) This fix should be back ported to all 2017 version!

    2018.1.b12 or b13 still has the same problem BTW. So the above issue tracker that saying it is fixed for 2018.1 is something that I am not so sure about.? Can anyone confirm the fix in any version of Unity 2017.x ? or 2018.x ?

    This issue has been going on for so long... I am sadly got used to restarting Unity after every 30mins..
     
  32. TheLadyApollo

    TheLadyApollo

    Joined:
    Nov 27, 2017
    Posts:
    4
    Same problem here...
    Disabling windows realtime protection really did the trick for me.
    I'm on 2018.1.b013
     
  33. Dokkanosaur

    Dokkanosaur

    Joined:
    Jul 18, 2017
    Posts:
    9
    Basically identical situation to @castor76

    I'm also running a GTX 970 here. My game usually runs at 200+ FPS but since 2017.3 basically just drops to 5FPS randomly, even on practically empty scenes, while in the editor. Overhead is consuming 95%+, with no traces of why in the deep profiler.

    As mentioned above, the build of the game is perfect. This only happens in the editor. It's an incredibly frustrating issue, and seems to pop in and out without warning.

    What is going on???
     
  34. IronBeagle_6

    IronBeagle_6

    Joined:
    Aug 28, 2014
    Posts:
    1
    Same thing on my end aswell.
    With GTX 1070 working on VR and Editor.Overhead takes everything.
     
  35. AnderX003

    AnderX003

    Joined:
    Feb 14, 2018
    Posts:
    1
    If I correctly understood that editorOverpeed takes memory only when working with Unity, and if I compile the game (under Android), then on the phone this problem will not be?
     
  36. Cover-Club-Media

    Cover-Club-Media

    Joined:
    Apr 30, 2015
    Posts:
    52
    Same here. I thought it was something on my end for a while, disabled some objects and did some refactoring but this performance sucker won't go away!
     
  37. Filhanteraren

    Filhanteraren

    Joined:
    May 14, 2014
    Posts:
    42
    Had the same issue, editor overhead taking 98~ %. Had the editor with custom window layout on dual screens and did a reset to default layout. Now it runs good again.
     
  38. Cover-Club-Media

    Cover-Club-Media

    Joined:
    Apr 30, 2015
    Posts:
    52
    As you said it does go away when in default. But it appears to return when you try any custom layout. Did that happen to you too?
     
  39. Filhanteraren

    Filhanteraren

    Joined:
    May 14, 2014
    Posts:
    42
    No, made a new custom layout and it seems to work as usual.
     
    Cover-Club-Media likes this.
  40. Beerfootbandit

    Beerfootbandit

    Joined:
    Aug 18, 2017
    Posts:
    2
    I disconnected my internet(phone tethering) and started in offline mode and it worked
     
  41. Robdon

    Robdon

    Joined:
    Jan 10, 2014
    Posts:
    98
    I'm getting similar problems, currently on 2018.1.0f2

    Randomly, when playing in the editor I get 6fps and it runs too slow to be able to do anything.

    Even when my game is just in the menu, the fps is 6.

    The only way I can solve this, is to reboot the PC. Restarting just the editor doesn't help.

    The rest of the machine is fine, and there is nothing else running in Task Manager.

    Looking at the profiler its 'EditorOverhead'.

    upload_2018-7-2_12-42-23.png
     
  42. Silly_Rollo

    Silly_Rollo

    Joined:
    Dec 21, 2012
    Posts:
    475
    I started getting this too on 2018.1.6f1
     
  43. WorldEater

    WorldEater

    Joined:
    Oct 23, 2014
    Posts:
    2
    For anyone having this issue, I have found that having unity scripts open in your IDE while in runtime can cause the application to run MUCH slower. By shutting the IDE down while running, my editor overhead fell by several hundred ms.

    Hope this helped someone with this annoying bug.
     
  44. Murgilod

    Murgilod

    Joined:
    Nov 12, 2013
    Posts:
    5,597
    I had this same problem and the source was the most bizarre thing:

    If I disabled Shadowplay on my GeForce card, the problem just... went away. Completely. I don't know what it is, but Shadowplay really hates the Unity editor.
     
  45. ShantiGaudreault

    ShantiGaudreault

    Unity Technologies

    Joined:
    Aug 17, 2015
    Posts:
    9
    Hi,
    I am trying to make sense of this thread. The problem with Editor Overhead is that its a broad category that contains everything that is not strictly the game. Everything the Editor does is in there.

    Current workarounds mentioned in this thread:
    • Disable Shadowplay on my GeForce card
    • Shutting down the IDE while in play mode. Which IDE, version and product would help?.
    • Resetting the layouts to default layouts really helped. This would be caused by some layout corruption.
    • Turning off windows defender real time protection.
    • Turning off windows firewall.
    • Not using tethered phone internet, going completely offline or on wifi/wire.
    I would like to be able to narrow it down a bit. We have to investigate quite a bit for some of those and its hard when we cannot reproduce easily.

    Anyone, with slowdowns not addressed by the workaround above please file an issue in the issue tracker or at the very least let us know in this thread. Any other workarounds that had success should be mentioned as they point to the root cause.
    2017.4 is our Long Term supported version and problems reported there get fixed.

    Also, fixes get released regularly so updating to the most recent 2017.4 LTS version is recommended.
    Thanks
    Shanti
     
    MNNoxMortem likes this.
  46. sonnyb

    sonnyb

    Joined:
    Nov 5, 2013
    Posts:
    10
    For me, this workaround works, but this is only because the Default layout does not necessarily show the Scene view.

    If the Scene view window is visible (e.g. when using 2 by 3 Layout, or if the Scene view window is popped out separately), I experience high EditorOverhead and my framerate drops when running my game in the Unity Editor.

    Additional info:
    • I'm on Unity 2018.2.10f1. I upgraded my project recently and I've only just noticed this issue. (I am upgrading from Unity 2017.3.f1 - I did not notice this issue there.)
    • The other workarounds in this thread did not help.
     
  47. GuardHei

    GuardHei

    Joined:
    Feb 10, 2018
    Posts:
    40
    Unity 2018.2.5f1, Mac, same issue. EditorOverHead takes over 160ms.
     
  48. JediNizar

    JediNizar

    Joined:
    Nov 13, 2016
    Posts:
    43
    Unity 2018.2.9f1, PC, same issue EditorOverHead takes 60% 15.35ms
     
  49. foxes

    foxes

    Joined:
    Oct 9, 2015
    Posts:
    9
    recently updated one of unity editors to version 2017.4.18f1 and began to notice this problem. Аnd additionally in version 2017.4.19f1 audio manager also began to occupy 50%. Total they take a couple of 100% of the busy time in free scene.
     
    Last edited: Feb 3, 2019
  50. alexquare

    alexquare

    Joined:
    Dec 11, 2017
    Posts:
    1
    This worked for me, the other solutions mentioned in the thread didn't. I was having this issue with Unity 2018.2.14f1, with the Editor overhead sometimes consuming 99% of CPU, sometimes the game would play at 7.8ms and in the next run at 15ms~16ms without any changes to the project, and never to come back again to the previous fps. But once I got rid of the Scene view the game ran at 5.9ms~6.2ms at all times.