Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Bug [2017.1.0b8] "Failed to load package manager".

Discussion in 'Linux Editor' started by Latty, May 15, 2017.

  1. Latty

    Latty

    Joined:
    May 5, 2014
    Posts:
    16
    On a system with previous version working, when trying to use the new 2017.1.0b3 release, when I load my project, I get a lot of console logs:

    Code (csharp):
    1. Failed to load package manager
    2. UnityEditor.Modules.ModuleManager:InitializePlatformSupportModules()
    3.  
    4. Failed to load package manager
    5. UnityEditor.Scripting.ScriptCompilation.EditorCompilationInterface:CompileScripts(EditorScriptCompilationOptions, BuildTargetGroup, BuildTarget)
    6.  
    7. NullReferenceException: Object reference not set to an instance of an object
    8. UnityEditor.Scripting.APIUpdaterHelper.ConfigurationProviderAssembliesPathArgument () (at /home/builduser/buildslave/unity/build/Editor/Mono/Scripting/APIUpdaterHelper.cs:134)
    9. UnityEditor.Scripting.APIUpdaterHelper.DoesAssemblyRequireUpgrade (System.String assemblyFullPath) (at /home/builduser/buildslave/unity/build/Editor/Mono/Scripting/APIUpdaterHelper.cs:105)
    In then proceed to get continuous, infinite logs of:

    Code (csharp):
    1. Failed to load package manager
    2. UnityEngine.GUIUtility:processEvent(Int32, IntPtr)
    The editor runs very slowly and nothing works. Hoping this is just an issue my end, please get back to me if you need more info.
     
  2. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    975
    This could be a bad installation - can you remove and reinstall Unity?
     
  3. Latty

    Latty

    Joined:
    May 5, 2014
    Posts:
    16
    Just did a wipe and a fresh install (downloaded the beta again and checked it's sha256sum), same issue.

    Using the Arch AUR script to make a package for it (https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=unity-editor-beta) that doesn't do anything special, really. It worked previously, and the only change was to update to the new build.
     
  4. Latty

    Latty

    Joined:
    May 5, 2014
    Posts:
    16
    Still having this problem as of 2017.1.0b8.
     
  5. f3flight

    f3flight

    Joined:
    Jun 14, 2017
    Posts:
    12
    Same issue here, Arch Linux x64, latest beta.
     
  6. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    187
    Hi there,

    I just fixed the AUR package, let me know if you still have problems. The problem was that some of the directories in ` Editor/Data/UnityExtensions/Unity/VR` didn't have the proper permissions for some reason. I think this might affect other distros that are using the .sh package.

    Cheers,
     
  7. ImranKhalil

    ImranKhalil

    Joined:
    Dec 5, 2014
    Posts:
    13
    I am facing this issue in 2017.1.1 p3 fressh install
     
  8. maramak

    maramak

    Joined:
    Mar 7, 2016
    Posts:
    1
    Latest at this moment Unity 2017.2. Fresh install. Failed to start Unity Package Manager: operation timed out.
     
  9. Riko_w

    Riko_w

    Joined:
    Oct 19, 2017
    Posts:
    1
    Salut a tous
    Même problème, je ne comprends pas d'ou cela viens ...
    je l'ai désinstallé puis ré-installé mais rien y fait..
     
  10. Autinhorse

    Autinhorse

    Joined:
    Jan 7, 2016
    Posts:
    2
    Same problem with Unity 2017.2. Working on a new project today, when tried to open another project which I worked with for more than half year, it could not open and told me "Unity package manager error" failed to start unity package manager: operation time out. And I tried the new project which I just closed, same issue.
     
  11. Autinhorse

    Autinhorse

    Joined:
    Jan 7, 2016
    Posts:
    2
    This should be an issue related different network. It worked well in my office, when I went outside working in an education center of my children, I met the problem, even I changed to hotpot of my mobile phone, the problem still there. But when I back to home now, it works well again.
     
  12. MACHIN3

    MACHIN3

    Joined:
    May 25, 2016
    Posts:
    61
    If you use the download assistant of 2017.3.0b1 and run it as super user to install Unity into /opt/Unity-2017.3.0b1, which is where I want it to be, the installation will seem to succeed, but Unity will produce the "Failed to load package manager" error message after launching the Editor.

    Installation in the home dir, works fine.
    Installation in the home dir and moving it manually into /opt/... will also produce the error message.

    Hope this can be fixed @Tak
     
  13. macrod

    macrod

    Joined:
    Dec 9, 2012
    Posts:
    22
    "Failed to start Unity Package Manager" happens if I use Lantern and Disconnect it from system tray.
     
  14. Odd-Redesign

    Odd-Redesign

    Joined:
    Jul 26, 2013
    Posts:
    134
    This happens for me in 2017.2

    There are wrong permissions in UnityExtensions/VR/ and PlaybackEngines/Facebook that are causing issues.
     
  15. PJayB

    PJayB

    Unity Technologies

    Joined:
    Apr 24, 2017
    Posts:
    105
    I'll look into this. Thanks for reporting.
     
    MACHIN3 likes this.
  16. irenya

    irenya

    Joined:
    Nov 22, 2017
    Posts:
    10
    Same issue here. I'm on a Mac, running El Capitan, with Unity 2017.2.0f3.
    Have been on this version for over a week now, without any issues. Worked perfectly fine earlier today, shut down Unity the regular way, have tried to re-open the project I am working on and i'm getting this error.

    The editor.log doesn't say much at all:

    [Package Manager] Server::Start -- Port 61125 was selected
    Launching external process: /Applications/Unity/Unity.app/Contents/Tools/nodejs/bin/node

    And nothing else. One of the times I tried it, it got a longer error, stating some timeout issue. I'm 100% sure my internet connection was working at the time (although it may have been a bit slow).

    Just leaving this here in case it helps someone. The issue did sort itself out after retrying 4 or 5 times, fortunately, so it could have simply been a connection issue either on my side or some temporary server glitch.
     
  17. MehanGames

    MehanGames

    Joined:
    May 27, 2017
    Posts:
    1
    Same issue. I tried it latest version, betas, older versions... All of them not working.

    edit: it's fixed when i disable windows firewall.
     
    Last edited: Dec 13, 2017
  18. kedwards

    kedwards

    Joined:
    Feb 19, 2015
    Posts:
    1
    Same issue.
    ubuntu 16.04.3 LTS
    Unity 2017.3.0b1

    Errors in Console summated as:

    Failed to load package Manager
    ...InitializeModeuleManager()
    ..InitializePlatformSupportModules() ## 3 attempts
    Couldn't call method UNetDomainReload....bc the class NetworkIdentity couldn't be found
    ...InitializeModeuleManager()
    ..InitializePlatformSupportModules()
    ...RegisterAdditionalUnityExtensions()
    Couldn't call method UNetDomainReload....bc the class NetworkIdentity couldn't be found
    ...GUIUtility.ProcessEvent(Int32, IntPtr) ## approx 50 attempts

    Essentially makes Unity freeze-up
     
  19. aniket444

    aniket444

    Joined:
    Dec 24, 2017
    Posts:
    1
    Same issue here have a Unity 2017.3.0f3 version in windows 10 worked fine with previous versions ,but after updating ,
    it displays the message "Failed to startup Unity Package Manager".Plzz help somebody!!
     

    Attached Files:

  20. RetroZelda

    RetroZelda

    Joined:
    Jan 8, 2013
    Posts:
    6
    I've gotten around it by running the editor(2017.3) as root
     
  21. gsizer

    gsizer

    Joined:
    Jan 24, 2018
    Posts:
    2
    As the only user on my machine running Debian 9, the following got rid of the nasty package manager error.

    "sudo chown $USER --recursive /opt/Unity-2017.3.0p2"
     
    Andrey-Postelzhuk and adappsdev like this.
  22. adappsdev

    adappsdev

    Joined:
    Jan 23, 2018
    Posts:
    1
    I had the same prooblem and this solved for me.

    Thanks a lot.
     
  23. Andrey-Postelzhuk

    Andrey-Postelzhuk

    Joined:
    Nov 26, 2013
    Posts:
    73
    Ubuntu 16.04 Solved the problem for me too. Thanks @gsizer
     
  24. okba28mca

    okba28mca

    Joined:
    Aug 22, 2010
    Posts:
    86
    Hello guys !
    This issue seems to be related to your network as well
    I was facing it and scratching my head then I remember that I'm using proxy for my windows .
    Disabling it solved my issue .
    Quick fix you should try will be : type internet option in the search bar .
    Go to advanced tab and click Reset ( reset to the default settings )
     
  25. alienboysd2004

    alienboysd2004

    Joined:
    Dec 26, 2017
    Posts:
    1
     
  26. offmonreal

    offmonreal

    Joined:
    Mar 23, 2018
    Posts:
    10
    Encountered this problem in the version Unity-2017.4.0f1
    I knew that it was a bad idea to install Unity from root user.
    But I did it by accident. :confused:
    Then I just transferred the files and gave the folder "Unity-2017.4.0f1" the rights of my user.
    Also has solved that the problem is solved.
    Units started issuing these errors.
    Then I changed the group to my user with write rights
    This solved the problem. :)
     
  27. miniduck

    miniduck

    Joined:
    Sep 27, 2012
    Posts:
    117
    Running 2018b13, set http_proxy to something bogus and it will fail.
    (giving it internet access and it launches fine)
    Got this in editor.log
     
unityunity