Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

[1.1.3]Can not Start App In Android

Discussion in 'Addressables' started by m-nakayama, Jun 19, 2019.

  1. m-nakayama

    m-nakayama

    Joined:
    Jun 12, 2018
    Posts:
    8
    hi

    I updated AAS from 0.8.4 to 1.1.3.
    I rebuilded All Assets for Android,and Uploaded.

    So I could not start app.

    Logs said "FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies".

    I can play app in Editor(Packed Play Mode and Fast Mode).

    Thank you.

    Logs:
     
  2. stefankohl

    stefankohl

    Joined:
    May 30, 2014
    Posts:
    43
    I've ran into the same problem a few minutes ago on a Standalone build. Debugging into the ResourceManager code revealed that this was caused during preparing a list of resource locations and loading required assemblies. The location in questions points to an AnimatorController which is part of the UnityEditor.Animation namespace (hence part of the UnityEditor assembly that is not present in the player).

    AFAIK, animators used in the player are derived from RuntimeAnimatorController, so I guess something went wrong during pack time, causing an editor asset to be packed into a bundle?

    EDIT: The exception occurs in ResourceManagerConfig.cs:262 called from ContentCatalogData.cs:277-278
     
  3. David_GameDev

    David_GameDev

    Joined:
    Dec 25, 2016
    Posts:
    23
    Same Problem here. Rebuild and Updated, but it doesn´t seem to work on mobile.
    In Editor everything is fine.
    It did work in 0.8.6

    Code (CSharp):
    1. 06-19 14:34:00.158: E/Unity(16338): FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies
    2. 06-19 14:34:00.158: E/Unity(16338):   at System.AppDomain.Load (System.String assemblyString, System.Security.Policy.Evidence assemblySecurity, System.Boolean refonly) [0x00000] in <00000000000000000000000000000000>:0
    3. 06-19 14:34:00.158: E/Unity(16338):   at UnityEngine.ResourceManagement.Util.LRUCacheAllocationStrategy.Release (System.Int32 typeHash, System.Object obj) [0x00000] in <00000000000000000000000000000000>:0
    4. 06-19 14:34:00.158: E/Unity(16338):   at UnityEngine.AddressableAssets.ResourceLocators.ContentCatalogData.CreateLocator (System.String providerSuffix) [0x00000] in <00000000000000000000000000000000>:0
    5. 06-19 14:34:00.158: E/Unity(16338):   at UnityEngine.AddressableAssets.Initialization.InitializationOperation.OnCatalogDataLoaded (UnityEngine.AddressableAssets.AddressablesImpl addressables, UnityEngine.ResourceManagement.AsyncOperations.AsyncOperationHandle`1[TObject] op, System.String providerSuffix) [0x00000] in <00000000000000000000000000000000>:0
    6. 06-19 14:34:00.158: E/Unity(16338):   at System.Func`2[T,TResult].In
    7.  
     
    Last edited: Jun 19, 2019
  4. nonamenanasisan

    nonamenanasisan

    Joined:
    May 17, 2019
    Posts:
    3
    Same problem.
    My error logs.

    06-19 21:28:30.343: E/Unity(8511): FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies
    06-19 21:28:30.343: E/Unity(8511): at System.AppDomain.Load (System.String assemblyString, System.Security.Policy.Evidence assemblySecurity, System.Boolean refonly) [0x00000] in <00000000000000000000000000000000>:0
    06-19 21:28:30.343: E/Unity(8511): at System.AppDomain.Load (System.String assemblyString) [0x00000] in <00000000000000000000000000000000>:0
    06-19 21:28:30.343: E/Unity(8511): at UnityEngine.ResourceManagement.Util.LRUCacheAllocationStrategy.Release (System.Int32 typeHash, System.Object obj) [0x00000] in <00000000000000000000000000000000>:0
    06-19 21:28:30.343: E/Unity(8511): at UnityEngine.AddressableAssets.ResourceLocators.ContentCatalogData.CreateLocator (System.String providerSuffix) [0x00000] in <00000000000000000000000000000000>:0
    06-19 21:28:30.343: E/Unity(8511): at UnityEngine.AddressableAssets.Initialization.InitializationOperation.OnCatalogDataLoaded (UnityEngine.AddressableAssets.AddressablesImpl addressables, UnityEngine.ResourceManagement.AsyncOperations.AsyncOperationHandle`1[TObject] op, Syst
     
  5. unity_bill

    unity_bill

    Unity Technologies

    Joined:
    Apr 11, 2017
    Posts:
    954
    stefankohl and David_GameDev like this.
  6. Wawro01

    Wawro01

    Joined:
    Apr 23, 2014
    Posts:
    30
    Same for iOS here :(

    Code (CSharp):
    1. FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies
    2.   at System.AppDomain.Load (System.String assemblyString, System.Security.Policy.Evidence assemblySecurity, System.Boolean refonly) [0x00000] in
     
  7. stefankohl

    stefankohl

    Joined:
    May 30, 2014
    Posts:
    43
    Updating to 1.1.4 fixed this for me!
     
    unity_bill likes this.
  8. m-nakayama

    m-nakayama

    Joined:
    Jun 12, 2018
    Posts:
    8
    Ver1.1.4 fixed Android and iOS.

    Thank you for AAS's developers !
     
    unity_bill likes this.
  9. wangyucheng1992

    wangyucheng1992

    Joined:
    Feb 19, 2019
    Posts:
    52
    A question about async. https://forum.unity.com/threads/await-addressables-instantiateasync-but-fail.698015/